Tangoe SFTP and eft.tangoe.com Notification

Incident Report for Tangoe Mobile

Resolved

Our secure file transfer protocol (SFTP) servers and eft.tangoe.com are now fully restored. Any data uploaded to eft.tangoe.com between 10:30 AM Eastern thru 2:51 PM Eastern may need to be uploaded again. There is no risk of incorrect files or wrong data being passed to the SFTP sites. It is highly suggested that all owners re-run / check their processes for accurate results following this interruption.
Posted Oct 22, 2025 - 16:22 EDT

Update

Recovery mitigations across services are progressing. Our teams are in the process of bringing up the system database servers.
Posted Oct 22, 2025 - 15:25 EDT

Update

The Tangoe infrastructure has power fully restored at the Production Data Center. Our teams are in the process of bringing systems back online in a prioritized and controlled manner to ensure stability and performance. Recovery updates will be sent as systems are fully accessible.
Posted Oct 22, 2025 - 14:10 EDT

Identified

Tangoe is receiving power recovery alerts from the Production Data Center. As power stabilizes, our teams will be bringing systems back online in a prioritized and controlled manner to ensure stability and performance. Recovery updates to follow.
Posted Oct 22, 2025 - 12:44 EDT

Investigating

Tangoe has received notification from our Production Data Center of a power event. This is also potentially impacting our secure file transfer protocol (SFTP) servers and eft.tangoe.com. Our Technical teams are pending resolution to restore full service as expediently as possible. Updates will follow as available
Posted Oct 22, 2025 - 11:31 EDT
This incident affected: Tangoe Mobile Portal.