The Amazon Web Services (AWS) service disruption reported yesterday is fully resolved. All AWS services have returned to normal operations.
Posted Oct 21, 2025 - 09:22 EDT
Monitoring
Tangoe continues to monitor the Amazon Web Services (AWS) service disruption reported earlier today. AWS has confirmed recovery efforts are progressing across all of their impacted services, and the overall performance has stabilized.
Posted Oct 20, 2025 - 16:39 EDT
Investigating
Tangoe is aware of a widespread service disruption currently affecting Amazon Web Services (AWS). At this time, there is no impact to Tangoe systems or our customers. All platforms are operating normally. We are closely monitoring the situation and will notify you if any changes occur.
Posted Oct 20, 2025 - 09:12 EDT
This incident affected: Tangoe Mobile Portal, Tangoe Custom Solutions Portals, Tangoe CRM (née Bluefish CRM), and Helpdesk Services.